ASP .NET

Si hay algo de lo que en Microsoft puedan estar orgullosos, sin duda son sus entornos de programación. Cuando encuentran algún problema grave no intentan hacer la vista gorda. Y por eso son tan valorados. Desde la party EkoParty, se le notificó a Microsoft un agujero de seguridad en ASP.NET framework, las librerías que muchos usuarios tenemos instaladas.

Según Microsoft, el problema es potencialmente peligroso en Windows XP, Vista, Windows 7 y Windows Server 2008 y 2003, es decir, todos los sistemas operativos modernos de la compañía. Al parecer, el problema no está siendo explotado y su peligrosidad radica en que permite a algún usuario malintencionado descifrar ficheros y datos que sólo el usuario o el servidor web deberían poder visualizar.

Según las primeras investigaciones, la programación de hasta el 25% de las webs mediante el entorno de Microsoft utilizan la API vulnerable por lo que los atacantes podrían descifrar las comunicaciones entre el cliente y el servidor de un número muy alto de sitios web.

Por supuesto, siempre es recomendable utilizar algún software de seguridad como Avira Antivir o Nod32 Antivirus para minimizar cualquier riesgo de sufrir un ataque.

Fuente: CNet

Relacionados

Nos encanta escucharte ¿Nos dejas tu opinión?