Qué son las fórmulas de Excel

Las fórmulas son una de las características más útiles de Excel que abren la puerta de otros algoritmos de cálculo más complejos como son las funciones. En todo caso, son los responsables de que Excel sea una de las herramientas más potentes que existen.

Básicamente, las fórmulas nos permiten realizar cálculos y la primera orden que van a llevar va a ser el carácter ”=”. Ojo que es muy importante conocer los criterios de Excel para que una fórmula sea introducida correctamente, si no será una fuente de error constante. Para introducir una fórmula lo más cómodo es ir a la barra de fórmulas, situada en la parte superior de la interfaz de Excel.

Pero veámoslo con un ejemplo. En una hoja Excel tú puedes limitarte a transcribir una factura introduciendo los datos manualmente y calcular el total y el IVA con una calculadora. Eso es un completo error.

Es mucho más sencillo y útil añadir en la celda que queremos introducir el total un “=” seguido de las celdas a adicionar separadas por “+”.  Así, la orden “=B3+B4+B5+B6+B7” devolverá de forma automática el resultado de sumar las celdas B3, B4, B5, B6 y B7. La ventaja de todo esto es que si varías cualquiera de esos valores referenciados, Excel actualizará el resultado. Con las funciones iremos un paso más allá al simplificar este cálculo introduciendo “=SUMA(B3:B7)”, pero eso ya lo veremos en otro apartado.

Sigamos con los ejemplos de la factura. Si asignas a la casilla B8 la introducción del IVA en formato porcentaje y actualmente escribes el 21 (que es el IVA actual vigente en España para productos estándar), ésta celda afectará al total gravándolo, es decir, tendremos que aplicar la fórmula “=B8*TOTAL” y si un día cambia la retención al 23%, bastará con modificar la casilla destinada al IVA para que desde ese momento todas tus facturas y albaranes se actualicen con el nuevo impuesto de valor añadido.

Las fórmulas permiten la introducción de largas y complicadas operaciones matemáticas que se ejecutarán de forma correcta siempre y cuando sigamos los criterios de Excel, su lenguaje de introducción de datos y la jerarquía de las operaciones matemáticas.